logo
 
WebChain/2 Previous Ramdom Jump WebChain/2 Home Next
 メインメニュー
 サイト内検索

検索オプション
 ログイン
ユーザID または e-mail:

パスワード:

IDとパスワードを記憶

パスワード紛失

新規登録
 IRC(チャット)
#OS/2:*.jp
楽しみ方はこの辺参照.
News:OS/2 : Qt version 4.7.3 for OS/2 and eCS
投稿者: MSakai 投稿日時: 2011/09/16 12:37:45 (2287 ヒット)



Qt 4.7.3 for OS/2がリリースされました。

ftp://ftp.netlabs.org/pub/qt4/4.7.3/

必須環境
- A OS/2 Warp 4 Fixpack 16+, OS/2 Warp 4.5 or eComStation operating system.
- LIBC library version 0.6.3
- GCC 4 Core Libraries

- Extended system tray widget for XCenter version 0.1.1 or above (optional)
- eCUPS 1.4.8 or later to support printing from Qt 4 applications (optional):
http://svn.netlabs.org/ecups/wiki/CupsPort
- OpenSSL DLLs for OpenSSL support and for MySQL/PostgresSQL plugins to operate (optional)

なお今回より WarpIn パッケージでの提供はなくなりましたが、セットアップにあたっては旧バージョンを削除してからという手順はいつもどおり。






印刷用ページ このニュースを友達に送る
投稿された内容の著作権はコメントの投稿者に帰属します。

投稿者 スレッド
MSakai
投稿日時: 11/09/23 13:54  更新日時: 12/06/06 21:48
Home away from home
登録日: 11/07/14
居住地: フィリピン海プレート上の静岡県
投稿数: 288
 Re: Qt version 4.7.3 for OS/2 and eCS
最近システムを入れ替えたら Qt が起動しなくなったのでメモ。

ハードウェア
IBM ThinkCentre S50/Cel-2.66GHz/RAM 1.5GB/HDD 80GB
ディスク構成は以前と変わらず。all JFS

eComStation 2.1 JA preview ただしインストールオプションはまさぐってある(覚えてないけど。汗)。

libc 0.63-csd3.wpi 適用(不要)
gcc-core.wpi 適用(一部必要)
libc 0.64-csd4.wpi 適用
gcc-core-1_2_1.wpi 適用
libc 0.65-csd5.wpi 適用

Qt 4.7.3.1 展開→CONFIG.SYS 編集

・・・とやってみたのだが、Qtアプリのプロパティ画面で止まってしまう。

おぬし、またも PATH 行が長いというオチではあるまいな

【6/6追記】解決しました。

GCC 4 Runtime の前提条件である kLIBC Runtime 0.6.4 CSD4 にはlibc-0.6.4-csd4.wpilibc-0_6_4-csd4.wpiの2種類あることに気がついた。しかもアンダーバーの後者をインストールしても、ちゃんとセットアップされたようにみえるのが問題かな
Powered by IBM OS/2 Warp, Apache, PHP, MySQL and XOOPS Cube