logo
 
WebChain/2 Previous Ramdom Jump WebChain/2 Home Next
 メインメニュー
 サイト内検索

検索オプション
 ログイン
ユーザID または e-mail:

パスワード:

IDとパスワードを記憶

パスワード紛失

新規登録
 IRC(チャット)
#OS/2:*.jp
楽しみ方はこの辺参照.
フォーラム一覧   -   トピック一覧
   アプリ
     FirefoxとThunderbirdの同時起動不可
投稿するにはまず登録を

スレッド表示 | 新しいものから 前のトピック | 次のトピック | 下へ
投稿者 トピック
youfo
投稿日時: 08/04/03 19:18
Not too shy to talk
登録日: 06/10/10
居住地: 愛媛県
投稿: 28
FirefoxとThunderbirdの同時起動不可
環境
Firefox  :2.0.0.13
Thunderbird:2.0.0.12
OS/2    :WARP 4.0
今までは、バージョンが異なると、xpcomcor.dllのエラーで後から起動したアプリケションが実行できませんでした。
→xpcomcor.dllが異なるため(FxとTbのバージョンが異なっても、xpcomcor.dllが同じであれば起動する)

今回の場合は、xpcomcor.dllは同じなのに、後から起動したアプリケーションが実行できませんでした。
Fx → Tb で実行した場合:LIBC05.DLL 0001:0000861c でエラー
Tb → Fx で実行した場合:LIBC05.DLL 0001:00014d0d でエラー
LIBC05.DLLでエラーなので、Thunderbird!.exe(RUN! 0.7)を使用してもエラーとなる。

LIBC05.dll 356,330byte 04/04/14 16:37:42

原因、対策があれば、よろしくお願いします。
                        from youfo
torakun
投稿日時: 08/04/03 21:07
Home away from home
登録日: 03/02/07
居住地: 兵庫県
投稿: 214
Re: FirefoxとThunderbirdの同時起動不可
v1.5時代から同時起動って出来なかったけど、環境によっちゃ出来たのかな?
Firefox2.0+Thunderbird1.5でも駄目だったんだけど。取り合えずこれで同時起動は可能ですよ。

OS2.jp FAQ
Mozilla系アプリケーションの複数同時起動
http://www.os2.jp/modules/xoopsfaq/index.php?cat_id=7#q6
youfo
投稿日時: 08/04/03 21:30
Not too shy to talk
登録日: 06/10/10
居住地: 愛媛県
投稿: 28
Re: FirefoxとThunderbirdの同時起動不可
torakunさんは書きました:

> v1.5時代から同時起動って出来なかったけど、環境によっちゃ出来たのかな?
> Firefox2.0+Thunderbird1.5でも駄目だったんだけど。取り合えずこれで同時起動は可能ですよ。
>
> OS2.jp FAQ
> Mozilla系アプリケーションの複数同時起動
> http://www.os2.jp/modules/xoopsfaq/index.php?cat_id=7#q6

Fx2.0 + Tb1.5 では駄目ですが(dllのバージョンが異なるため)、Fx2.0.0.12 + Tb2.0.0.9は、dllが同じなので同時起動できます。
今回は、Fx、Tbが各々持っているdllでなく、OS/2共通のlibc05.dllで発生しているため、OS2.jp FAQは該当しません。
→一応、FAQの「RUN!使用も確認済み」が質問投稿内容にあり

                         from youfo
torakun
投稿日時: 08/04/03 22:30
Home away from home
登録日: 03/02/07
居住地: 兵庫県
投稿: 214
Re: FirefoxとThunderbirdの同時起動不可

youfoさんは書きました:

Fx2.0 + Tb1.5 では駄目ですが(dllのバージョンが異なるため)、Fx2.0.0.12 + Tb2.0.0.9は、dllが同じなので同時起動できます。
今回は、Fx、Tbが各々持っているdllでなく、OS/2共通のlibc05.dllで発生しているため、OS2.jp FAQは該当しません。
→一応、FAQの「RUN!使用も確認済み」が質問投稿内容にあり

                         from youfo


ああ、ごめんなさい。
Firefoxも2.0.0.13が出ていることに気づいて無くてバージョンを合わせて試しましたが、当方では何の問題もありませんでした。
お役にたてない上に、お手をかけて申し訳ないです。
achain
投稿日時: 08/04/03 22:35
Webmaster
登録日: 03/01/26
居住地: とーきょー じゃぺーん
投稿: 2597
Re: FirefoxとThunderbirdの同時起動不可
>LIBC05.DLLでエラーなので、Thunderbird!.exe(RUN! 0.7)を使用してもエラーとなる。

Thunderbird!L.exe ではどうでしょうか?
youfo
投稿日時: 08/04/04 08:03
Not too shy to talk
登録日: 06/10/10
居住地: 愛媛県
投稿: 28
Re: FirefoxとThunderbirdの同時起動不可
torakunさんは書きました:

> Firefoxも2.0.0.13が出ていることに気づいて無くてバージョンを合わせて試しましたが、当方では何の問題もありませんでした。

Fx2.0.0.13 + Tb2.0.0.12 + WARP4.0 の組み合わせでしょうか。

achainさんは書きました:

> Thunderbird!L.exe ではどうでしょうか?

Firefox.exe → Thunderbird!L.exe(0.75)で実行してみましたが、改善されませんでした(前回と同エラー)。

環境が悪いのかと思い(Fxは、2.0.0.12に上書き:旧プロファイル)、
・新規に、Fx2.0.0.12をインストール(新プロファイル)
 →Fx、Tbの同時起動可
・新規に、Fx2.0.0.13をインストール(新プロファイル)
 →Fx、Tbの同時起動不可
                         from youfo
achain
投稿日時: 08/04/04 09:18
Webmaster
登録日: 03/01/26
居住地: とーきょー じゃぺーん
投稿: 2597
Re: FirefoxとThunderbirdの同時起動不可
>Firefox.exe → Thunderbird!L.exe(0.75)で実行してみましたが、改善されませんでした(前回と同エラー)。

もしかして!Lの効かない環境(非Auroraカーネル)なのかな?
Warp4のFixレベルはいかほどなのでしょうか。

ちなみに我が家ではFirefox 2.0.0.13とThunderbird 2.0.0.12の同時起動はFAQにある方法で問題ないです。(Warp 4.52,RUN! 0.60)
RUN!を使わないと確かにLIBC05でエラー吐きますが。
youfo
投稿日時: 08/04/04 10:51
Not too shy to talk
登録日: 06/10/10
居住地: 愛媛県
投稿: 28
Re: FirefoxとThunderbirdの同時起動不可
achainさんは書きました:

> もしかして!Lの効かない環境(非Auroraカーネル)なのかな?
> Warp4のFixレベルはいかほどなのでしょうか。

Warp 4.0 FX00505(FixPak15は未適用)です。
これって、WarpINも駄目で、RUN!(dllバージョン不一致時の動作)も駄目でした(過去のコメントより)。

> ちなみに我が家ではFirefox 2.0.0.13とThunderbird 2.0.0.12の同時起動はFAQにある方法で問題ないです。
> (Warp 4.52,RUN! 0.60)
> RUN!を使わないと確かにLIBC05でエラー吐きますが。

RUN!を使用しないとエラーになるのであれば、私の環境では駄目ということですね。
→libc05.dllでエラーとなっているが、Fx、Tbのdllバージョン不一致ということ?
→Thunderbird2.0.0.13を待つしかない(出るかは?)

                        from youfo
achain
投稿日時: 08/04/04 14:47
Webmaster
登録日: 03/01/26
居住地: とーきょー じゃぺーん
投稿: 2597
Re: FirefoxとThunderbirdの同時起動不可
>→libc05.dllでエラーとなっているが、Fx、Tbのdllバージョン不一致ということ?

挙動からするとそうでしょうね。何かコールバックを使っていたりするとlibc05.dll→Mozilla系DLLという呼び出し順もあるでしょうし。

>→Thunderbird2.0.0.13を待つしかない(出るかは?)

Enhanced版(PmW-Fx/PmW-Tb)は使えませんか?
公式版/Enhanced版どちらも厳密にはソフトウェア要件がFixPak15以降であることに変わりはないのですが,Enhanced版がFX00505環境でも無事動くのであれば,そちらの方が今後も安心な気がします。少なくともFxとTbはほぼ確実に同時リリースされていますので。
youfo
投稿日時: 08/04/04 19:44
Not too shy to talk
登録日: 06/10/10
居住地: 愛媛県
投稿: 28
Re: FirefoxとThunderbirdの同時起動不可
achainさんは書きました:

> Enhanced版(PmW-Fx/PmW-Tb)は使えませんか?
> 公式版/Enhanced版どちらも厳密にはソフトウェア要件がFixPak15以降であることに変わりはないのですが,
> Enhanced版がFX00505環境でも無事動くのであれば,そちらの方が今後も安心な気がします。
> 少なくともFxとTbはほぼ確実に同時リリースされていますので。

PmW-Fxを試してみました。結果は、「Firefox 3.0β」と同じ現象になりました。
・実行しても全く起動されない(30分経過しても)。CPU100%状態
 →CPU:233MHz、メモリー:96MB の環境(ThinkPad560X)
 →PmW-Firefox 2.0.0.1の頃は、動作してたのに([Firefox 2.0のフィッシング対策機能について]の動作検証)

                        from youfo
スレッド表示 | 新しいものから 前のトピック | 次のトピック | トップ

投稿するにはまず登録を
 
Powered by IBM OS/2 Warp, Apache, PHP, MySQL and XOOPS Cube